SSD will not run past about 4000 rpm

If you need technical information or help with your BOSCH ignition squarecase Ducati 900SS - Darmah engine - post your FAQs, comments & questions here.
Post Reply
OZHoppo
Cucciolo - the Lil Pup
Posts: 9
Joined: Sun Feb 23, 2014 1:44 am

SSD will not run past about 4000 rpm

Post by OZHoppo » Fri Jan 19, 2018 1:38 am

Gurus,
I have an SSD with 40mm carbies.
Engine idles beautifully and blips very crisply but when taking it for a ride it accelerates normally from standstil up to about 60kmh but when throttling up to speed in a 100kmh zone the bike will not pull. It struggles to get to 4000rpm and then stops accelerating. There is a vibration that feels like the cylinders are out of whack or it is not advancing.
Float heights checked, carbies cleaned a dozen times, balanced using the BH method, no apparant air leaks using carby cleaner spray, pumpers delivering 5ml after 20 pumps.
Am i looking at the wrong things; could it be electrical - something like pickup gap, faulty ignition module or coil, etc.

Steve (Australia)

User avatar
Gardner
Cucciolo - the Lil Pup
Posts: 3
Joined: Thu Jul 17, 2008 5:09 am
Location: Davenport, Ia

Re: SSD will not run past about 4000 rpm

Post by Gardner » Sun Jan 21, 2018 6:35 am

Have you replaced the wires that run from the pickups inside the left engine cover and up to the
Bosch ignition boxes under the fuel tank?
1978 SD Darmah
1979 SSD Darmah
1981 900SS
2017 Desert Sled
1982 Bimota HB2

wdietz186
888
Posts: 652
Joined: Sun Sep 10, 2006 4:40 pm

Re: SSD will not run past about 4000 rpm

Post by wdietz186 » Sun Jan 21, 2018 1:20 pm

The pickup wires are probably deteriorated and shorting due the insulation falling apart. Harmonic vibration can cause intermittent shorting/misfire. But! I have had 3 bad Bosch ignition boxes fail in the past few years and the symptoms were what you describe. Ok running until the ignition goes to full advance and 1 of the boxes dies or doesn't advance fully,around 4k rpm. It can be checked if you have/or have access to the stroboscopic timing tool,you will see the difference when the revs approach 4k

OZHoppo
Cucciolo - the Lil Pup
Posts: 9
Joined: Sun Feb 23, 2014 1:44 am

Re: SSD will not run past about 4000 rpm

Post by OZHoppo » Sun Jan 21, 2018 5:59 pm

The pickup wires have been replaced and I swapped out the ignition boxes while I was under the tank

Taking the tank off (again) to check connections I discovered that I had crossed connected the ballast resistors so they were out of circuit. A quck change of connections and away she went. Will now pull evenly and up beyond 5000pm.... still running it in, so I did not take it above that.

Now just have to sort out the popping when it gets to around 4000rpm and on the overrun and I should be all good to go. I suspect that is just a case of sealing the cross-over pipe.

Thanks for the input.

User avatar
Craig in France
Cagiva Indiana
Posts: 787
Joined: Tue Mar 23, 2004 3:58 pm
Location: Montpellier, France

Re: SSD will not run past about 4000 rpm

Post by Craig in France » Tue Jan 23, 2018 1:33 am

OZHoppo wrote:
Sun Jan 21, 2018 5:59 pm
<snip> I discovered that I had crossed connected the ballast resistors so they were out of circuit. A quick change of connections and away she went.
Thanks for reporting back. That's one I haven't heard of before ... :shock:

OZHoppo
Cucciolo - the Lil Pup
Posts: 9
Joined: Sun Feb 23, 2014 1:44 am

Re: SSD will not run past about 4000 rpm

Post by OZHoppo » Wed Jan 24, 2018 2:37 am

Having a really good look around under the tank at the wiring showed up a number of issues including partially broken wires to the coils at the connections and a bunch of other issues.
I am chasing my tail with this and decided to go down a different path. I have ordered an Ignitech unit to go with new GT40 coils and high quality plug leads and resistor caps.
That way I can dispense with the Bosch coils and ignition units.

I will keep you posted on how the Ignitech unit performs.

OZHoppo
Cucciolo - the Lil Pup
Posts: 9
Joined: Sun Feb 23, 2014 1:44 am

Re: SSD will not run past about 4000 rpm

Post by OZHoppo » Mon Jan 29, 2018 3:15 am

Ignitech installed with Bosch GT40T coils.
After a bit of hassles with wiring connections the bike is running superbly. Idles at 1000rpm like a champ and pulls cleanly to 5000rpm (running in new engine).
The unit is plug and play and has resolved all the issues I was experiencing.

Post Reply

Return to “Squarecase BOSCH Ignition Engines > SD, SSD Darmah, late 900 SS & 900 GTS”