Page 1 of 1

Pantah 1980 500SL GEN light

Posted: Sat Aug 05, 2017 5:11 am
by Pantah-Nick
Hello,
Has anyone any experience of the following, the alternator light goes on and off repeatedly, it can be on for a few minutes then of for a while. In eighty odd miles yesterday resulted in me jumping the bike to get home. I can't see me riding for over an hour on the battery only, however the light being on is obviously indicative of not charging.
The battery is new and gives good voltage and holds a load on test, with fly leads to measure the output of the regulator or diode pack it reads just over 1 volt which would make sense if the light was always on but it's very often off for long periods.
A new regulator is available as NOS but runs around £200 so a better understanding of the issue would help before I spend the money.
The alternator output was good and no break down to earth through either lead which have been replaced resently.
I understand that the voltmeter controls the light and it can be on at low RPM with the alternator loaded up
I may splice in a voltmeter in the regulator output and ride the bike to gain a good understanding of the output but having had the bike for only a few weeks I have little experience of the system on a 1980 Duke?

Thanks, Nick.

Re: Pantah 1980 500SL GEN light

Posted: Mon Aug 07, 2017 10:08 am
by ducadini
As many times, electrickery killed the duck :~
Check the earthing on all connections, they were rather small to begin and with age coming in, they could"ve gone marginal.
And better still : check ALL connections and wires for dodgy repairs and getting stuck between hard things.
Luckily, a Pantah isn't too hard to jumpstart alone. (or am I translating it wrong and did You mean : add bigger battery ?)

ciao
ducadini

Re: Pantah 1980 500SL GEN light

Posted: Mon Aug 14, 2017 2:04 am
by Craig in France
Hi Nick (and welcome to the Forum),

As ducadini says, first check and clean all the connections, especially at the reg/rec itself.

Next check to see if the reg/rec is putting out. Stick a voltmeter across the battery and see if it rises when you rev the engine to around 3,500. If it doesn't, either the reg/rec isn't working or the alternator isn't.

(A really crude way to check the reg/rec is to see if it reg/rec gets hot in use :) . It should. As is, 'burny hot', so be careful).

To check the alternator, the easiest way is do a resistance test between the two leads. You should get someut around 3 Ohms (or so I seem to remember). But the actual reading isn't so important - at least, not at this stage. What is, is if it goes open circuit. This means that the winding in the stator has broken - = new (or rewound) stator.

But we're not there yet ... :)

EDIT: I see you wrote this:
Pantah-Nick wrote:
Sat Aug 05, 2017 5:11 am
The alternator output was good ...
How did you test it? What was its output?

P.s You're right: the idiot light on the Pantah is controlled by a volt meter. If it's the same one as on the Dramah, be aware that they're known for their unreliabilty ;).