500 Sport Desmo - Ignition

If you need technical information or help with your parallel twin Ducati GTL 350/500 or Sport Desmo 350/500 engine - post your FAQs, comments & questions here.
Post Reply
Chris Bushell
Parallel Twin
Posts: 107
Joined: Wed Oct 22, 2008 8:26 am
Location: Sevenoaks UK
Contact:

500 Sport Desmo - Ignition

Post by Chris Bushell » Mon Apr 12, 2010 6:43 am

Well I have now started in ernest the running in process of this bike, so that we can make some proper use of it on the Moto Giro d'Italia in June.

With the family away I was able to get out both days over the weekend and look at getting some serious miles on round the wonderful leafy lanes of Kent.

At the end of each run I noticed that the bikes was running a bit rough. I checked the points and each time they have closed up a little, reset them and it is fine.

A close examination of the NOS points that I bought showed that they are not the same as the originals and that they are not sitting square on the base plate.

I called up a guy from Leeds who also has one of these bikes and he has put an electronic ignition on his, from a guy that normally does them for British twins and found it sucessful.

So I called the guy at lunch time and he remembered doing the job and appreciated the article in the April issue of Classic Bike about my bike. So the long and the short of it is that he is going to make me a kit, including the amplifier, pick-up plate and rotor for the middle of next week. I am going to extend the shaft that the advance retard fits on and also pack the base plate out by 30mm so that it is no long burried down a big hole.

Will post up more information once we have it running, but the cost looks like being less than 2 pairs of contact breakers that dont fit very well!

Chris

jcslocum
Cucciolo - the Lil Pup
Posts: 13
Joined: Mon Jan 25, 2010 8:10 am
Location: NY, USA

Post by jcslocum » Tue Apr 13, 2010 4:48 am

Can you post pictures once done??
Jon

Chris Bushell
Parallel Twin
Posts: 107
Joined: Wed Oct 22, 2008 8:26 am
Location: Sevenoaks UK
Contact:

Post by Chris Bushell » Wed Apr 14, 2010 8:09 am

Don't worry will do - if this works then it will solve some of the problems of trying to set points down a narrow hole.

Chris

Chris Bushell
Parallel Twin
Posts: 107
Joined: Wed Oct 22, 2008 8:26 am
Location: Sevenoaks UK
Contact:

Post by Chris Bushell » Tue Jul 13, 2010 7:38 am

Well the kit is finally on its way to me and I should get a chance to do the fitting at the weekend. There is already one UK bike running with this set-up and it made the whole of the Motogiro d'Italia without any problems.

I should have mine up and running in a couple of weeks and will then pass on the details of the kit to Steve, so that US owners can get it through him.

Chris

Den
Mach 3
Posts: 89
Joined: Fri Apr 09, 2004 5:02 pm
Location: Florida, USA

Post by Den » Fri Aug 27, 2010 6:23 pm

So, whatever happened?

Chris Bushell
Parallel Twin
Posts: 107
Joined: Wed Oct 22, 2008 8:26 am
Location: Sevenoaks UK
Contact:

Post by Chris Bushell » Wed Sep 08, 2010 8:46 am

There are times when work gets in the way of the important things in life - this has been one of them!

I intend to get back on it this weekend.

Chris

Den
Mach 3
Posts: 89
Joined: Fri Apr 09, 2004 5:02 pm
Location: Florida, USA

Post by Den » Mon Dec 06, 2010 4:25 pm

So, whatever happened?

.

Chris Bushell
Parallel Twin
Posts: 107
Joined: Wed Oct 22, 2008 8:26 am
Location: Sevenoaks UK
Contact:

Post by Chris Bushell » Thu Dec 16, 2010 2:30 am

Waiting for the Christmas break and the snow to go away, so that I can fit it.

The water in the de-humidifier is frozen this morning!

Chris

machten
MHR / S2
Posts: 481
Joined: Sun Oct 29, 2006 8:37 am
Location: Perth, Western Australia

Post by machten » Thu Dec 16, 2010 7:21 am

Chris,

The fact that you guys are under feet of snow right now is not relevent. Put your gloves, thermals, and balaclavas on and get out to the shed. You really need to harden up a bit. :P

Hang in there!

Kev

Den
Mach 3
Posts: 89
Joined: Fri Apr 09, 2004 5:02 pm
Location: Florida, USA

Post by Den » Sun Apr 03, 2011 5:37 pm

So, whatever happened?

User avatar
DesmoBro
Mariana
Posts: 28
Joined: Sat Feb 26, 2011 10:26 am
Location: Gardner Ma

Re: 500 Sport Desmo - Ignition

Post by DesmoBro » Fri Apr 06, 2012 10:24 pm

So I understand that things are busy, My Desmo hasn't been up and running since the 80's(before i was born)...Someone probably was busy from then til now...But Now here I am ready to pull the trigger on one of these electronic ignitions...I do hope to hear some updates soon, I have this itch and the only way to scratch it is by Driving The Desmo 5 I have been eyeballing for 2 years that doesn't run because of no spark and no hope...Please Help
Attachments
ducsize2.jpg
....For some reason I decided to build a Fish Bike.....
http://www.dotheton.com/forum/index.php?topic=34163.0

Post Reply

Return to “Parallel Twin Engines > GTL/Sport Desmo 350 & 500”